Jon (j_b) wrote,
Jon
j_b

  • Location:
  • Mood:

The joys of closed-source hardware drivers

I administer several IBM eServer xSeries 306 servers ( Make: 8836 Model: 4SU ) running Red Hat Enterprise Linux 4.3 x86_64 (oo, certified hardware!), with the onboard Adaptec ServeRAID-7e SATA ( driver: aarich )

For the initial install , the drivers IBM provides in ibm_dd_aarich_4.00.63_rhel4u3_x86_64.tar work, because the initial install uses kernel 2.6.9-34.EL

Red Hat has released 4 security advisories requiring kernel updates to fix:
RHSA-2006:0617 Important: kernel security update 8/22/06
RHSA-2006:0575 Updated kernel packages available for Red Hat Enterprise Linux 4 Update 4 8/10/06
RHSA-2006:0574 Important: kernel security update 7/7/06
RHSA-2006:0493 Important: kernel security update 5/24/06

The latest kernel is 2.6.9-42.0.2.EL , but I cannot install it without a new aarich driver.

I've twice attempted to contact IBM support, twice been called back by technicians who do not understand the problem, and keep trying to have me browse to various incorrect drivers on the site.

YAY.
Tags: ♥♥♥ tech support
Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 0 comments