Jon (j_b) wrote,
Jon
j_b

  • Music:

error: SANE: Error during device I/O (code=9)

Trying to get a Hewlett Packard Color LaserJet CM1017 MFP working with Ubuntu 10.10

Having installed the various HPLIP devices and detected/configured the printer, trying to run the bundled installer:

The "hp-setup" utility silently fails to download the proprietary scanner driver from hplip.sf.net - so I needed to browse to http://hplip.sourceforge.net/plugin.conf and manually download the correct-version ".run" file from http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.10.6-plugin.run , manually specify the downloaded file's location, and I had to make sure I was root (using sudo) when running "hp-setup".

This brought me to a state where the hp-toolbox utility could see the printer (and the print drivers were installed).

Attempting to run "hp-scan" exited with "error: SANE: Error during device I/O (code=9)". Other scanning attempts with hp-toolbox bombed out with a GUI dialog "Failed to scan" "Unable to connect to scanner" and console output "** (simple-scan:3837): WARNING **: Unable to get open device: Error during device I/O"

I found the solution here: https://answers.launchpad.net/hplip/+question/18354 which involved going to /usr/lib and making a symlink named libhpmud.so to libhpmud.so.0 :

$ cd /usr/lib
$ sudo ln -s libhpmud.so.0 libhpmud.so

Now scanning works.
Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 2 comments